Prihlásiť sa | Zabudnuté heslo | Registrovať

X

What is OpenID?

OpenID is an Internet-wide identity system that allows you to sign in to many websites with a single account.

With OpenID, your ID becomes a URL (e.g. http://username.myopenid.com/). You can get a free OpenID for example from myopenid.com.

For more information visit the official OpenID site.

42 príspevkov v 14 témach | 13 členov

Skok na:

Moduly

Ak ste na stránke prvý kát, nezabudnite sa zaegistrovať! Vďaka registrácii budete môcť aktívne vstúpiť do diskusného fóra (vytvoriť Vlákno alebo pridať príspevok do existujúceho vlákna).

Diskusné fórum » Moduly » Chyba po inštalácii modulu silverstripe-multisites a korektné odinštalovanie modulu

Strana: 1 Dole
Autor Téma: Chyba po inštalácii modulu silverstripe-multisites a korektné odinštalovanie modulu 1165 Views
  • matok
    Avatar
    Community Member
    1 posts

    Chyba po inštalácii modulu silverstripe-multisites a korektné odinštalovanie modulu Link to this post

    Ahojte,
    opakovane som sa pokúšal nainštalovať cez composera http://addons.silverstripe.org/add-ons/silverstripe-australia/silverstripe-multisites vrátane http://addons.silverstripe.org/add-ons/silverstripe/multivaluefield, ktorý vyžaduje. Dovtedy bolo všetko OK, ale po nainštalovaní tohto modulu sa stránka nezobrazila správne, vysypal sa namiesto nej fragment html kódu, v ktorom bola začlenená chybová hláška: Fatal error: Call to a member function setStatusCode() on a non-object in C:\wamp\www\pokus\framework\dev\Debug.php on line <i>340</i></th> Nič iné okrem inštalácie som nerobil, žiadne úpravy kódu.
    Potom som sa pokúsil odinštalovať tento modul spôsobom, ako som sa dočítal na silverstripe.org/community/forums/ a síce vymazanie príslušného foldra modulu a následne mysite/dev/build?flush=1. Potom som skúsil refresh, ale namiesto stránky zobrazilo v Chrome, že je príliš veľké množstvo redirectov a vo Firefoxe zobrazilo menu a zopár vecí, ale bez CSS formátovania a bola tam hláška, že daná stránka neexistuje.
    No toto nie je moc dobrý štart so Silverstripe , toľko som o ňom počul/čítal chvál a teraz zisťujem, že je to akési celé nedoriešené.
    Podobne som sa pokúšal cez composera nainštalovať blog. V prvej inštalácii to šlo, ale keďže som musel som reinštalovať z dôvodu toho chybného modulu multisites (úplne iný nový názov stránky) a potom už composer vypísal, že mu chýba http://addons.silverstripe.org/add-ons/silverstripe/tagfield, hoci som ho predtým nainštaloval. Tak už fakt neviem.
    Fórum pre verziu 3.1.13 som pre zmenu ani vôbec nenašiel v ponuke modulov.
    No je to CMS asi len pre silné nervy, ale rád by som sa mýlil Snažil som sa postupovať podľa tutoriálov a návodov, ale neviem, kde je chyba.

    1165 Views
Hore

Práve online: Nikto nie je online.

Najnovší člen fóra: petersevruk